Task5.1: SW3 NOT receive EGP routes from R2

Dear All:
Why I could not get any BGP routes which advertise out by R2?
The below is the Advertisement from R2, send out on Vlan29, but SW3 did not receive anything. Both neighbors are up:

*********************** From router 2 *****************
Rack1R2#show ip bgp neighbors 136.1.29.9 advertised-routes
BGP table version is 41, local router ID is 150.1.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*> 28.119.16.0/24 136.1.23.3 0 100 54 i
*> 28.119.17.0/24 136.1.23.3 0 100 54 i
*> 112.0.0.0 136.1.23.3 0 100 54 50 60 i
*> 113.0.0.0 136.1.23.3 0 100 54 50 60 i
*> 114.0.0.0 136.1.23.3 0 100 54 i
*> 115.0.0.0 136.1.23.3 0 100 54 i
*> 116.0.0.0 136.1.23.3 0 100 54 i
*> 117.0.0.0 136.1.23.3 0 100 54 i
*> 118.0.0.0 136.1.23.3 0 100 54 i
*> 119.0.0.0 136.1.23.3 0 100 54 i

Total number of prefixes 10

********* from SW3 *********************
Rack1SW3#show ip bgp summary
BGP router identifier 150.1.9.9, local AS number 100
BGP table version is 1, main routing table version 1

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
136.1.29.2 4 300 257 249 1 0 0 03:38:40 0
136.1.109.10 4 100 246 246 1 0 0 03:38:48 0
**************** From SW3 ***********
Rack1SW3#show ip bgp neighbors 136.1.29.2 received-routes

Total number of prefixes 0

Comments

  • All your routes on R2 have AS100 in the as-path list. Consequently, when R2 advertises them to SW3 - SW3 won't accept them since it's in AS100 - this is BGP's way of stopping loops.

    Task 5.6 is a way around this problem and allowing AS 100 routes into a router in AS 100.

    rich
Sign In or Register to comment.