IPv6: 9.5 (Latest)

Hi INE

I did not issue the command "no ipv6 nd suppress-ra" and was surprised to see that it is configured under the FastEthernet interface 0/0 for this task in SG. For me this command did not produce any difference in the working of auto-config.  In SG, the reason to use this command is that "supress-ra" is enabled by default on Ethernet Interfaces.

As per Cisco's documentation, As soon as "ipv6 unicast-routing" is configured and an Ipv6 address is configured, router advertisements are sent out that interface by default, so they are not suppressed by default on Ethernet interfaces:

 


 ipv6 nd ra suppress



To suppress IPv6 router advertisement transmissions on a LAN interface, use the ipv6 nd ra suppress command
in interface configuration mode. To reenable the sending of IPv6 router
advertisement transmissions on a LAN interface, use the no form of this command.


ipv6 nd ra suppress


no ipv6 nd ra suppress



Syntax Description



This command has no arguments or keywords.



Command Default



IPv6 router advertisements are automatically sent on Ethernet and FDDI
interfaces if IPv6 unicast routing is enabled on the interfaces. IPv6
router advertisements are not sent on other types of interfaces. 

Therefore, as per Cisco there is no need to issue this command unless it is configured already. Please shed some light on it. Thanks.

 

Comments

  • By applying only the first portion of the configuration on R5 as listed in the Solution Guide we get:

    R5#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    R5(config)#ipv6 unicast-routing
    R5(config)#!
    R5(config)#interface FastEthernet 0/0
    R5(config-if)# ipv6 address fc00:1:0:58::5/64
    R5(config-if)# ipv6 address fc00:1:0:85::5/64
    R5(config-if)# ipv6 nd prefix fc00:1:0:58::/64 14400 14400 no-autoconfig
    R5(config-if)# ipv6 nd prefix fc00:1:0:85::/64 14400 14400
    R5(config-if)# ipv6 nd ra-interval 40
    R5(config-if)# ipv6 nd ra-lifetime 60
    R5(config-if)#do sh run int f0/0
    Building configuration...

    Current configuration : 299 bytes
    !
    interface FastEthernet0/0
     no ip address
     shutdown
     duplex auto
     speed auto
     ipv6 address FC00:1:0:58::5/64
     ipv6 address FC00:1:0:85::5/64
     ipv6 nd prefix FC00:1:0:58::/64 14400 14400 no-autoconfig
     ipv6 nd prefix FC00:1:0:85::/64 14400 14400
     ipv6 nd ra lifetime 60
     ipv6 nd ra interval 40
    end

    R5(config-if)#

    As you can see there is no "automatic" placement of the "no" version of the command.

    According to your own post:


    "IPv6 router advertisements are automatically sent on Ethernet and FDDI
    interfaces if IPv6 unicast routing is enabled on the interfaces. IPv6
    router advertisements are not sent on other types of interfaces."

    Therefore the default mode would be


    ipv6 nd ra suppress

    Thus:

    no ipv6 nd ra suppres

    Would be required to stop the IPv6 router advertisments per the lab.

    We reverified these tasks and found them to work as prescribed.

    Hope This Helps!

    --The TechEdit Team

  • Hi INE

    Thanks for your reply but i am afraid it is not clear enough to reply to my query. 

    What i had asked is that by default, as soon as IPV6 routing is enabled and an IPv6 Address is configured on an interface, it starts sending out RA.

    In this task, we needed to advertise two prefixes along with their required parameters so we did that via "ipv6 nd prefix". As per Cisco, By default, prefixes configured as addresses on an interface using the ipv6 address command are advertised in router advertisements. If you configure prefixes for advertisement using the ipv6 nd prefix command, then only these prefixes are advertised. Therefore as these two prefixes are advertised Only, which we have addressed as per task requirement, why do i need to do "no ipv6 ra suppress" ????? you mean to say that we needed to advertise all the prefixes (probably as an scalability requirement) and not only these two on this Interface?

    Regards

  • We apologize.  We miss read your initial post. Based on the
    information you have provided your observations seem correct.  However,
    we are trying to finish up BGP, and once that is done we will
    immediately give this lab a relook before moving to QoS. It may be a
    few days before we can do this but it will be next on our task list.

    --TechEdit Team

     

  • Sorry for the delay.  We reverified this lab and after consideration we have determined that your observations are indeed correct.  The application of the "no ipv6 nd ra suppress" command is indeed over configuration. We will remove this command in the next revision of the document, pending approval of the Instructor Team. Nice catch!

    --The TechEdit Team

     

  • Hello TechEdit Team,


    i know you guys are very busy reviewing labs but as of today, this issue has still not been changed.


    Thanks for doing all you can as it brings confusion.


    Cheers [:D]

  • Hi,

    I'm running a 2811 as my R5 and noticed that the syntax was different for the ra lifetime and interval when compared to the solution guide:

    ipv6 nd ra lifetime 40

    ipv6 nd ra interval 40

    Anyone else noticed this?

    Thanks,

    Chris

  • Yes I noticed this too:

     

    interface FastEthernet0/0
     ip address 155.1.58.5 255.255.255.0
     ip rip advertise 10
     duplex auto
     speed auto
     ipv6 address FC00:1:0:58::5/64
     ipv6 address FC00:1:0:85::5/64
     ipv6 nd prefix FC00:1:58::/64 14400 14400 no-autoconfig
     ipv6 nd prefix FC00:1:85::/64 14400 14400
     ipv6 nd ra lifetime 60
     ipv6 nd ra interval 40
    end

  • That was confusing me too. Thanks for the pickup ie_ccie_2209

     

    Another thing I noted was that if you forget to add the default keyword on the ned. A reload is required to get the default router information onto SW2. Maybe there is another way but I tried

    1. Shut/no shut

    2. No ipv6 address autoconfig

    3. reload 

Sign In or Register to comment.