OSPF stuck in EXSTART (Resolved)

Could anyone help me on this one.  I've loaded the WB VOL1 v5 FULL OSPF ROUTING initial config and made NO changes to the config.  It seems that R1, R2, R3 refuse to become neighbours over the F/R cloud.  The debug ip ospf adj output is below.

 

Rack4R1#
Feb 19 12:19:46.683: OSPF: Send DBD to 150.4.3.3 on Serial0/0 seq 0xE28 opt 0x52 flag 0x7 len 32
Feb 19 12:19:46.683: OSPF: Retransmitting DBD to 150.4.3.3 on Serial0/0 [16]
Feb 19 12:19:47.537: OSPF: Send DBD to 150.4.2.2 on Serial0/0 seq 0xC37 opt 0x52 flag 0x7 len 32
Feb 19 12:19:47.537: OSPF: Retransmitting DBD to 150.4.2.2 on Serial0/0 [25]
Rack4R1#
Feb 19 12:19:51.684: OSPF: Send DBD to 150.4.3.3 on Serial0/0 seq 0xE28 opt 0x52 flag 0x7 len 32
Feb 19 12:19:51.684: OSPF: Retransmitting DBD to 150.4.3.3 on Serial0/0 [17]
Feb 19 12:19:52.537: OSPF: Killing nbr 150.4.2.2 on Serial0/0 due to excessive (25) retransmissions
Feb 19 12:19:52.537: OSPF: 150.4.2.2 address 155.4.0.2 on Serial0/0 is dead, state DOWN
Rack4R1#
Feb 19 12:19:52.537: %OSPF-5-ADJCHG: Process 1, Nbr 150.4.2.2 on Serial0/0 from EXSTART to DOWN, Neighbor Down: Too many retransmissions
Rack4R1#
Feb 19 12:19:56.684: OSPF: Send DBD to 150.4.3.3 on Serial0/0 seq 0xE28 opt 0x52 flag 0x7 len 32
Feb 19 12:19:56.684: OSPF: Retransmitting DBD to 150.4.3.3 on Serial0/0 [18]

 

I know it's not an MTU issue, nor is it a duplicate router id.  I thought it could be a uncast related issue but I can ping 150.4.3.3 and obviously  R3 can ping R1.  All I know is that the DBD packets are not being recives.

So im completely stimped and have spent next to all my rack time trying to resolve this.  Any help would be welcome.

I did make a post regarding a similar problem, in that case I was using a combination of interface level and router level commands to enable ospf.  That issue was eventually resolved by using the interface only enabler on all routers.  Funny thig was it was the same routers last time too.

Comments












  • Could you post your config for R1,R2 & R3?

     

    Thanks

     

    Shahid

     

    From: [email protected]
    [mailto:[email protected]] On Behalf Of Geekazoid

    Sent: Friday, February 19, 2010 3:41 PM

    To: [email protected]

    Subject: [CCIE R&S] OSPF stuck in EXSTART

     

    Could anyone help me on this one.  I've loaded the WB VOL1 v5 FULL OSPF
    ROUTING initial config and made NO changes to the config.  It seems that
    R1, R2, R3 refuse to become neighbours over the F/R cloud.  The debug ip
    ospf adj output is below.

     

    Rack4R1#

    Feb 19 12:19:46.683: OSPF: Send DBD to 150.4.3.3 on Serial0/0 seq 0xE28 opt
    0x52 flag 0x7 len 32

    Feb 19 12:19:46.683: OSPF: Retransmitting DBD to 150.4.3.3 on Serial0/0 [16]

    Feb 19 12:19:47.537: OSPF: Send DBD to 150.4.2.2 on Serial0/0 seq 0xC37 opt
    0x52 flag 0x7 len 32

    Feb 19 12:19:47.537: OSPF: Retransmitting DBD to 150.4.2.2 on Serial0/0 [25]

    Rack4R1#

    Feb 19 12:19:51.684: OSPF: Send DBD to 150.4.3.3 on Serial0/0 seq 0xE28 opt
    0x52 flag 0x7 len 32

    Feb 19 12:19:51.684: OSPF: Retransmitting DBD to 150.4.3.3 on Serial0/0 [17]

    Feb 19 12:19:52.537: OSPF: Killing nbr 150.4.2.2 on Serial0/0 due to excessive
    (25) retransmissions

    Feb 19 12:19:52.537: OSPF: 150.4.2.2 address 155.4.0.2 on Serial0/0 is dead,
    state DOWN

    Rack4R1#

    Feb 19 12:19:52.537: %OSPF-5-ADJCHG: Process 1, Nbr 150.4.2.2 on Serial0/0 from
    EXSTART to DOWN, Neighbor Down: Too many retransmissions

    Rack4R1#

    Feb 19 12:19:56.684: OSPF: Send DBD to 150.4.3.3 on Serial0/0 seq 0xE28 opt
    0x52 flag 0x7 len 32

    Feb 19 12:19:56.684: OSPF: Retransmitting DBD to 150.4.3.3 on Serial0/0 [18]

     

    I know it's not an MTU issue, nor is it a duplicate router id.  I
    thought it could be a uncast related issue but I can ping 150.4.3.3 and
    obviously  R3 can ping R1.  All I know is that the DBD packets are
    not being recives.

    So im completely stimped and have spent next to all my rack time trying to
    resolve this.  Any help would be welcome.

    I did make a post regarding a similar problem, in that case I was using a
    combination of interface level and router level commands to enable ospf. 
    That issue was eventually resolved by using the interface only enabler on all
    routers.  Funny thig was it was the same routers last time too.







    Internetwork Expert - The Industry Leader in CCIE Preparation

    http://www.internetworkexpert.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx





  • R1

    ---

     

    Rack4R1#sh run
    Building configuration...

    Current configuration : 1356 bytes
    !
    ! Last configuration change at 12:54:51 UTC Fri Feb 19 2010
    ! NVRAM config last updated at 10:31:22 UTC Fri Feb 19 2010
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Rack4R1
    !
    boot-start-marker
    boot-end-marker
    !
    enable password cisco
    !
    no aaa new-model
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    ip cef
    !
    !        
    !
    !
    no ip domain lookup
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !        
    !
    !
    !
    interface Loopback0
     ip address 150.4.1.1 255.255.255.0
     ip ospf 1 area 0
    !
    interface FastEthernet0/0
     ip address 155.4.146.1 255.255.255.0
     ip ospf 1 area 1
     duplex auto
     speed auto
    !
    interface Serial0/0
     ip address 155.4.0.1 255.255.255.0
     encapsulation frame-relay
     ip ospf network point-to-multipoint
     ip ospf hello-interval 10
     ip ospf 1 area 0
     frame-relay map ip 155.4.0.5 105 broadcast
     no frame-relay inverse-arp
    !
    interface Serial0/1
     ip address 155.4.13.1 255.255.255.0
     ip ospf 1 area 4
    !
    router ospf 1
     router-id 150.4.1.1
     log-adjacency-changes
     area 1 virtual-link 150.4.6.6
    !
    !
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !        
    !
    !
    !
    !
    line con 0
     exec-timeout 0 0
     privilege level 15
     logging synchronous level 0 limit 20
    line aux 0
     exec-timeout 0 0
     privilege level 15
    line vty 0 4
     password cisco
     login
    !
    !
    end

    Rack4R1#

  • R2

    -----

     

    Rack4R2#sh run
    Building configuration...

    Current configuration : 1325 bytes
    !
    ! Last configuration change at 12:47:13 UTC Fri Feb 19 2010
    ! NVRAM config last updated at 10:31:22 UTC Fri Feb 19 2010
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Rack4R2
    !
    boot-start-marker
    boot-end-marker
    !
    enable password cisco
    !
    no aaa new-model
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    ip cef
    !
    !        
    !
    !
    no ip domain lookup
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !        
    !
    !
    !
    interface Loopback0
     ip address 150.4.2.2 255.255.255.0
     ip ospf 1 area 0
    !
    interface FastEthernet0/0
     ip address 192.10.4.2 255.255.255.0
     ip ospf 1 area 51
     duplex auto
     speed auto
    !
    interface Serial0/0
     ip address 155.4.0.2 255.255.255.0
     encapsulation frame-relay
     ip ospf network point-to-multipoint
     ip ospf hello-interval 10
     ip ospf 1 area 0
     frame-relay map ip 155.4.0.5 205 broadcast
     no frame-relay inverse-arp
    !
    interface Serial0/1
     ip address 155.4.23.2 255.255.255.0
     ip ospf 1 area 5
    !
    router ospf 1
     router-id 150.4.2.2
     log-adjacency-changes
    !
    !
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !        
    !
    !
    !
    line con 0
     exec-timeout 0 0
     privilege level 15
     logging synchronous level 0 limit 20
    line aux 0
     exec-timeout 0 0
     privilege level 15
    line vty 0 4
     password cisco
     login
    !
    !
    end

    Rack4R2#

  • R2

    ---

     

    Rack4R2#sh run
    Building configuration...

    Current configuration : 1325 bytes
    !
    ! Last configuration change at 12:47:13 UTC Fri Feb 19 2010
    ! NVRAM config last updated at 10:31:22 UTC Fri Feb 19 2010
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Rack4R2
    !
    boot-start-marker
    boot-end-marker
    !
    enable password cisco
    !
    no aaa new-model
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    ip cef
    !
    !        
    !
    !
    no ip domain lookup
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !        
    !
    !
    !
    interface Loopback0
     ip address 150.4.2.2 255.255.255.0
     ip ospf 1 area 0
    !
    interface FastEthernet0/0
     ip address 192.10.4.2 255.255.255.0
     ip ospf 1 area 51
     duplex auto
     speed auto
    !
    interface Serial0/0
     ip address 155.4.0.2 255.255.255.0
     encapsulation frame-relay
     ip ospf network point-to-multipoint
     ip ospf hello-interval 10
     ip ospf 1 area 0
     frame-relay map ip 155.4.0.5 205 broadcast
     no frame-relay inverse-arp
    !
    interface Serial0/1
     ip address 155.4.23.2 255.255.255.0
     ip ospf 1 area 5
    !
    router ospf 1
     router-id 150.4.2.2
     log-adjacency-changes
    !
    !
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !        
    !
    !
    !
    line con 0
     exec-timeout 0 0
     privilege level 15
     logging synchronous level 0 limit 20
    line aux 0
     exec-timeout 0 0
     privilege level 15
    line vty 0 4
     password cisco
     login
    !
    !
    end

    Rack4R2#

  • R3

    ---

     

    Rack4R3#sh run
    Building configuration...

    Current configuration : 1562 bytes
    !
    ! Last configuration change at 12:51:21 UTC Fri Feb 19 2010
    ! NVRAM config last updated at 10:31:34 UTC Fri Feb 19 2010
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Rack4R3
    !
    boot-start-marker
    boot-end-marker
    !
    enable password cisco
    !
    no aaa new-model
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    ip cef
    !
    !        
    !
    !
    no ip domain lookup
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !        
    !
    !
    !
    interface Loopback0
     ip address 150.4.3.3 255.255.255.0
     ip ospf 1 area 0
    !
    interface FastEthernet0/0
     ip address 155.4.37.3 255.255.255.0
     ip ospf 1 area 2
     duplex auto
     speed auto
    !
    interface FastEthernet0/1
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    interface Serial1/0
     ip address 155.4.0.3 255.255.255.0
     encapsulation frame-relay
     ip ospf network point-to-multipoint
     ip ospf hello-interval 10
     ip ospf 1 area 0
     frame-relay map ip 155.4.0.5 305 broadcast
     no frame-relay inverse-arp
    !
    interface Serial1/1
     no ip address
     shutdown
    !
    interface Serial1/2
     ip address 155.4.13.3 255.255.255.0
     ip ospf 1 area 4
     clock rate 64000
    !
    interface Serial1/3
     ip address 155.4.23.3 255.255.255.0
     ip ospf 1 area 5
     clock rate 64000
    !
    router ospf 1
     router-id 150.4.3.3
     log-adjacency-changes
    !        
    !
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
     exec-timeout 0 0
     privilege level 15
     logging synchronous level 0 limit 20
    line aux 0
     exec-timeout 0 0
     privilege level 15
    line vty 0 4
     password cisco
     login
    !
    !

    end

  • Sorry I copied R2's config in twice.

  • Right reloading sorted it !!!!

    If only I did that in the first place would have saved me all this pain !

     

  • Geekazoid,

    Did you try "show frame-relay map"?

    The pesky mappings to 0.0.0.0 that sometimes occur during initial configuration will almost act as multiple default routes - sends traffic one way, but with no way to get back. The most reliable way to clear them is to "wr" and "reload"...

    Right reloading sorted it !!!!

    If only I did that in the first place would have saved me all this pain !

  • Darrell, your right, it's just pain in the backside.  I think the previous post where I was having a similar problem could have been sorted by doing a reload. 

    It was weird because I kept seeing the hello's reach the spokes through R5, which would cause it to start going through the neighbour relationship establishment process, however unicast OSPF DBD packet would never reach the neighbour, which caused it stay in EXSTART.

    I think I better update the other post aswel.

Sign In or Register to comment.