MLP Interleaving Disabled - with interface multilink and virtual-template

I'm having difficulties getting the interleaving activated on my multilink.  I first tried using a virtual template:

multilink virtual-template 1

interface serial0/1
 no ip address  
 ppp multilink
 

interface Virtual-Template1
 bandwidth 128
 ip address 155.1.45.4 255.255.255.0
 ip rip advertise 10
 ppp multilink
 ppp multilink fragment delay 10
 ppp multilink interleave

Virtual-Access2, bundle name is Rack1R5
  Endpoint discriminator is Rack1R5
  Bundle up for 00:00:45, total bandwidth 128, load 1/255
  Receive buffer limit 12192 bytes, frag timeout 1000 ms
  Interleaving disabled
    0/0 fragments/bytes in reassembly list
    0 lost fragments, 0 reordered
    0/0 discarded fragments/bytes, 0 lost received
    0x33 received sequence, 0x32 sent sequence
  Member links: 1 (max not set, min not set)
    Se0/1, since 00:00:45, 160 weight, 152 frag size

After a lot of troubleshooting I decided to just use a multilink interface:

interface Multilink1
 ip address 155.1.45.4 255.255.255.0
 ip rip advertise 10
 ppp multilink
 ppp multilink fragment delay 10
 ppp multilink interleave
 ppp multilink group 1

!
interface Serial0/1
 bandwidth 128
 no ip address
 encapsulation ppp
 fair-queue
 ppp multilink
 ppp multilink group 1

Multilink1, bundle name is Rack1R5
  Endpoint discriminator is Rack1R5
  Bundle up for 00:23:13, total bandwidth 128, load 243/255
  Receive buffer limit 12000 bytes, frag timeout 1000 ms
  Interleaving disabled
    0/0 fragments/bytes in reassembly list
    0 lost fragments, 0 reordered
    0/0 discarded fragments/bytes, 0 lost received
    0xAEF7 received sequence, 0x15EAB sent sequence
  Member links: 1 active, 0 inactive (max not set, min not set)
    Se0/1, since 00:23:13, 160 weight, 152 frag size
No inactive multilink interfaces

 That's when I thought maybe it was diabled because I wasn't pushing any traffic through it.  So I set up a push through that pipe using SLA.   The interleaving never became enabled.

Any ideas?

Comments

  • The solution to the problem has to do with where the fair queueing is placed. I had placed the fair-queueing (software queueing) on the physical interface.  The interleaving is activated by WFQ and allows smaller packets to interleaved between the larger fragments.

  • Can you be more specific?  When I removed fair queue from the serial and placed it on the multilink interface the interleaving became active.

     

    thanks.

  • Tammy,

    You need to have some sort of queuing configured on the interface, preferably via a service-policy. I had some problems with this too and came across this:

    http://www.cisco.com/en/US/tech/tk1077/technologies_tech_note09186a00800b6098.shtml#topic6

    First bullet reads:

    "MLPoATM/Frame Relay is currently only tested and
    supported with a
    service-policy attached to either the virtual-template or
    dialer-interfaces.
    Omitting the service-policy can cause the feature to not work. One
    example of
    this is documented in Cisco bug ID
    CSCdu19313
    (
    registered
    customers only)
    ."

    I had an issue once when the multilink just won't come up till I attached the service policy to it.

     

    Regards,

    Jorge

  • Aloha,

    old thread,

    but I just wanted to try to configure MLP with interface multilink and had first the same issue like Tammy.

    But I agree to both of you. :-)

    The solution is just to have some kind of queing on the multilink or virtual-template interface to priorize "small" packets, like voice,

    This could be implemented just with WFQ with the fair-que command on the interface multilink or interface virtual-template.

    Then the WFQ on the physical interface is inactive.

     

    Cheers

    Marcel

     

Sign In or Register to comment.