CSC topology why is routes not getting installed

 

                          | ------------------   |

                          | backbone n/w      |

R8--R6--R4---|-R1----R2----R3--|-R5----R7----R9(client)

                          |                                  |

                          |______________ |

CSC prob 

ISP not running MPLS 

Routers R1,R2and R3 are BackBone(carrier) n/w

R6 and R4 is 1 pop site 

and R5 and R7 ia another pop site 

R8 is external client A 

R9 is external client B


MPLS is enabled between R4----R1----R2---R3---R5


R4 and R5 area RR 

R4 peer with R6, R5 and R7 

R5 peer with R4, R6, R7 

all with loopbacks 


R6 and R8 has eBGP relationship 

R7 and R9 has eBGP relationship 


i have the routes of client (R9) installed in the BGP table of R6 as best route,but it is not advertising it to R8(client) 

vice versa for R9(site)  routes of R8 are in R7 BGP table but not advertising it to external peer R9 


why it is not advertising the routes to client????

 


 

Comments


  • hostname r1

    no aaa new-model

    memory-size iomem 5

    ip cef

     

    ip vrf ABC

     rd 1:1

     route-target export 1:1

     route-target import 1:1

    !

    !

    multilink bundle-name authenticated

     

    interface Loopback0

     ip address 1.1.1.1 255.255.255.255

    !

    interface FastEthernet0/0

     ip address 10.10.12.1 255.255.255.0

     duplex auto

     speed auto

     mpls ip

    !

    interface FastEthernet0/1

     ip vrf forwarding ABC

     ip address 20.20.14.1 255.255.255.0

     duplex auto

     speed auto

     mpls ip  

    !

    router ospf 10 vrf ABC

     router-id 11.11.11.11

     log-adjacency-changes

     redistribute bgp 100 subnets

     network 20.20.14.0 0.0.0.255 area 0

    !

    router ospf 100

     log-adjacency-changes

     network 1.1.1.1 0.0.0.0 area 0

     network 10.10.12.0 0.0.0.255 area 0

    !

    router bgp 100

     no bgp default ipv4-unicast

     bgp log-neighbor-changes

     neighbor 3.3.3.3 remote-as 100

     neighbor 3.3.3.3 update-source Loopback0

     !

     address-family vpnv4

     neighbor 3.3.3.3 activate

     neighbor 3.3.3.3 send-community extended

     exit-address-family

     !        

     address-family ipv4 vrf ABC

     redistribute ospf 10 vrf ABC match internal external 1 external 2

     no synchronization

     exit-address-family

    !

    _______________________________________________________________________________________________________________________


    hostname r2

    !

    boot-start-marker

    boot-end-marker

    !

    !

    no aaa new-model

    memory-size iomem 5

    ip cef

     

    !

    multilink bundle-name authenticated

     

    interface Loopback0

     ip address 2.2.2.2 255.255.255.255

    !

    interface FastEthernet0/0

     ip address 10.10.12.2 255.255.255.0

     duplex auto

     speed auto

     mpls ip

    !

    interface FastEthernet0/1

     ip address 10.10.23.2 255.255.255.0

     duplex auto

     speed auto

     mpls ip

    !

    router ospf 100

     log-adjacency-changes

     network 2.2.2.2 0.0.0.0 area 0

     network 10.10.12.0 0.0.0.255 area 0

     network 10.10.23.0 0.0.0.255 area 0


  • hostname r3

     

    no aaa new-model

    memory-size iomem 5

    ip cef

    !

     

    ip vrf ABC

     rd 1:1

     route-target export 1:1

    !

    !

    interface Loopback0

     ip address 3.3.3.3 255.255.255.255

    !

    interface FastEthernet0/0

     ip vrf forwarding ABC

     ip address 30.30.35.3 255.255.255.0

     duplex auto

     speed auto

     mpls ip

    !

    interface FastEthernet0/1

     ip address 10.10.23.3 255.255.255.0

     duplex auto

     speed auto

     mpls ip  

    !

    router ospf 10 vrf ABC

     router-id 33.33.33.33

     log-adjacency-changes

     redistribute bgp 100 subnets

     network 30.30.35.0 0.0.0.255 area 0

    !

    router ospf 100

     log-adjacency-changes

     network 3.3.3.3 0.0.0.0 area 0

     network 10.10.23.0 0.0.0.255 area 0

    !

    router bgp 100

     no bgp default ipv4-unicast

     bgp log-neighbor-changes

     neighbor 1.1.1.1 remote-as 100

     neighbor 1.1.1.1 update-source Loopback0

     !

     address-family vpnv4

     neighbor 1.1.1.1 activate

     neighbor 1.1.1.1 send-community extended

     exit-address-family

     !        

     address-family ipv4 vrf ABC

     redistribute ospf 10 vrf ABC match internal external 1 external 2

     no synchronization

     exit-address-family

     

    ____________________________________________________________________

    hostname r4

     

    no aaa new-model

    memory-size iomem 5

    ip cef

    !

    !

     

    !

    interface Loopback0

     ip address 4.4.4.4 255.255.255.255

    !

    interface FastEthernet0/0

     ip address 20.20.46.4 255.255.255.0

     duplex auto

     speed auto

    !

    interface FastEthernet0/1

     ip address 20.20.14.4 255.255.255.0

     duplex auto

     speed auto

     mpls ip

    !

    router ospf 10

     router-id 4.4.4.4

     log-adjacency-changes

     network 4.4.4.4 0.0.0.0 area 0

     network 6.6.6.6 0.0.0.0 area 0

     network 20.20.14.0 0.0.0.255 area 0

     network 20.20.46.0 0.0.0.255 area 0

    !

    router bgp 10

     bgp router-id 4.4.4.4

     no bgp default ipv4-unicast

     bgp cluster-id 4

     bgp log-neighbor-changes

     neighbor 5.5.5.5 remote-as 10

     neighbor 5.5.5.5 update-source Loopback0

     neighbor 6.6.6.6 remote-as 10

     neighbor 6.6.6.6 update-source Loopback0

     neighbor 7.7.7.7 remote-as 10

     neighbor 7.7.7.7 update-source Loopback0

     !

     address-family ipv4

     neighbor 5.5.5.5 activate

     neighbor 5.5.5.5 route-reflector-client

     neighbor 5.5.5.5 next-hop-self

     neighbor 6.6.6.6 activate

     neighbor 6.6.6.6 route-reflector-client

     neighbor 6.6.6.6 next-hop-self

     neighbor 7.7.7.7 activate

     neighbor 7.7.7.7 route-reflector-client

     neighbor 7.7.7.7 next-hop-self

     no auto-summary

     no synchronization

     exit-address-family


  • hostname R5

    !

     

    ip cef

    !

     

    interface Loopback0

     ip address 5.5.5.5 255.255.255.255

    !

    interface FastEthernet0/0

     ip address 30.30.35.5 255.255.255.0

     duplex auto

     speed auto

     mpls ip

    !

    interface FastEthernet0/1

     ip address 30.30.57.5 255.255.255.0

     duplex auto

     speed auto

    !

    router ospf 10

     router-id 5.5.5.5

     log-adjacency-changes

     network 5.5.5.5 0.0.0.0 area 0

     network 30.30.35.0 0.0.0.255 area 0

     network 30.30.57.0 0.0.0.255 area 0

    !

    router bgp 10

     bgp router-id 5.5.5.5

     no bgp default ipv4-unicast

     bgp cluster-id 5

     bgp log-neighbor-changes

     neighbor 4.4.4.4 remote-as 10

     neighbor 4.4.4.4 update-source Loopback0

     neighbor 6.6.6.6 remote-as 10

     neighbor 6.6.6.6 update-source Loopback0

     neighbor 7.7.7.7 remote-as 10

     neighbor 7.7.7.7 update-source Loopback0

     !

     address-family ipv4

     neighbor 4.4.4.4 activate

     neighbor 4.4.4.4 route-reflector-client

     neighbor 4.4.4.4 next-hop-self

     neighbor 6.6.6.6 activate

     neighbor 6.6.6.6 next-hop-self

     neighbor 7.7.7.7 activate

     neighbor 7.7.7.7 route-reflector-client

     neighbor 7.7.7.7 next-hop-self

     no auto-summary

     no synchronization

     exit-address-family

     

    ____________________________________________________________________

     

    hostname R6

    !

    ip cef

    interface Loopback0

     ip address 6.6.6.6 255.255.255.255

    !

    interface FastEthernet0/0

     ip address 20.20.46.6 255.255.255.0

     duplex auto

     speed auto

    !

    interface FastEthernet0/1

     ip address 172.10.68.6 255.255.255.0

     duplex auto

     speed auto

    !

    router ospf 10

     router-id 6.6.6.6

     log-adjacency-changes

     network 6.6.6.6 0.0.0.0 area 0

     network 20.20.46.0 0.0.0.255 area 0

     network 172.10.68.0 0.0.0.255 area 0

    !         

    router bgp 10

     bgp router-id 6.6.6.6

     no bgp default ipv4-unicast

     bgp log-neighbor-changes

     neighbor 4.4.4.4 remote-as 10

     neighbor 4.4.4.4 update-source Loopback0

     neighbor 5.5.5.5 remote-as 10

     neighbor 5.5.5.5 update-source Loopback0

     neighbor 172.10.68.8 remote-as 100

     !

     address-family ipv4

     neighbor 4.4.4.4 activate

     neighbor 4.4.4.4 next-hop-self

     neighbor 5.5.5.5 activate

     neighbor 5.5.5.5 next-hop-self

     neighbor 172.10.68.8 activate

     neighbor 172.10.68.8 next-hop-self

     no auto-summary

     no synchronization

     exit-address-family

    ____________________________________________________________________


  • ____________________________________________________________________

    hostname R7

     

    no aaa new-model

    memory-size iomem 5

    ip cef

    !

     

    !

    interface Loopback0

     ip address 7.7.7.7 255.255.255.255

    !

    interface FastEthernet0/0

     ip address 172.20.79.7 255.255.255.0

     duplex auto

     speed auto

    !

    interface FastEthernet0/1

     ip address 30.30.57.7 255.255.255.0

     duplex auto

     speed auto

    !

    router ospf 10

     router-id 7.7.7.7

     log-adjacency-changes

     network 7.7.7.7 0.0.0.0 area 0

     network 30.30.57.0 0.0.0.255 area 0

     network 172.20.79.0 0.0.0.255 area 0

    !         

    router bgp 10

     no bgp default ipv4-unicast

     bgp log-neighbor-changes

     neighbor 4.4.4.4 remote-as 10

     neighbor 4.4.4.4 update-source Loopback0

     neighbor 5.5.5.5 remote-as 10

     neighbor 5.5.5.5 update-source Loopback0

     neighbor 172.20.79.9 remote-as 100

     !

     address-family ipv4

     neighbor 4.4.4.4 activate

     neighbor 4.4.4.4 next-hop-self

     neighbor 5.5.5.5 activate

     neighbor 5.5.5.5 next-hop-self

     neighbor 172.20.79.9 activate

     neighbor 172.20.79.9 next-hop-self

     no auto-summary

     no synchronization

     exit-address-family

    __________________________________________________________________

     

    hostname R8

    !

    boot-start-marker

    boot-end-marker

    !

    !

    no aaa new-model

    memory-size iomem 5

    ip cef

    !

    !

    !

    !

    !

    multilink bundle-name authenticated

    !

    !         

     

    interface Loopback0

     ip address 8.8.8.8 255.255.255.255

    !

    interface FastEthernet0/0

     no ip address

     shutdown

     duplex auto

     speed auto

    !

    interface FastEthernet0/1

     ip address 172.10.68.8 255.255.255.0

     duplex auto

     speed auto

    !

    router bgp 100

     bgp router-id 8.8.8.8

     no bgp default ipv4-unicast

     bgp log-neighbor-changes

     neighbor 172.10.68.6 remote-as 10

     !        

     address-family ipv4

     neighbor 172.10.68.6 activate

     no auto-summary

     no synchronization

     network 8.8.8.8 mask 255.255.255.255

     exit-address-family

    !

     

    ____________________________________________________________________

    hostname R9

    !

    boot-start-marker

    boot-end-marker

    !

    !

    no aaa new-model

    memory-size iomem 5

    ip cef

     

    interface Loopback0

     ip address 9.9.9.9 255.255.255.255

    !

    interface FastEthernet0/0

     ip address 172.20.79.9 255.255.255.0

     duplex auto

     speed auto

    !

    interface FastEthernet0/1

     no ip address

     shutdown

     duplex auto

     speed auto

    !

    router bgp 100

     no bgp default ipv4-unicast

     bgp log-neighbor-changes

     neighbor 172.20.79.7 remote-as 10

     !

     address-family ipv4

     neighbor 172.20.79.7 activate

     no auto-summary

     no synchronization

     network 9.9.9.9 mask 255.255.255.255

     network 172.20.79.0 mask 255.255.255.0

     exit-address-family

    !

  • i think u need to use allowasin or as override feature

  • i think u need to use allowasin or as override feature


     

    that's 100% correct.

  • Well as said it worked out silly mistake as i was stretch to a limit at tht time 

    i got very well now with the configuration part 

    but i want little more depth about theory of CSC  where should i look out ..........

     

     

  • Well as said it worked out silly mistake as i was stretch to a limit at tht time 

    i got very well now with the configuration part 

    but i want little more depth about theory of CSC  where should i look out ..........

     

     

    Your issue wasn't about CsC, it was about AS_PATH. Remove the routers from R1 to R5, you should have the same issue.

    Bo

Sign In or Register to comment.