Vol 1 CUCM Lab section 2.20 - MGCP CAS

Hey Josh,

 

Having trouble getting my t1 CAS to register with CUCM. I get a rejected status. I followed the solution guide which I see that there are some ISDN cmds listed on the soludtion guide...this isn't PRI, there shouldn't be any isdn, for CAS right?

any thoughts?

 

Thanks,

Voicedog

Comments

  • Hey Voicedog,

     

    The rejected status is typically temporary, and should go away with a gateway reset from the configuration page. The ISDN bind command is left over from the PRI backhaul configuration, and you are correct, the ISDN commands won't affect/work with CAS.

  • Can't get passed this rejection status. I let the config sit overnight and reset the gateway in cucm and still getting rejected. I did every restart/reset possible on both the router and cucm and nada.

    I don't have a domain name in the config, (though i did try with a domain name but still no registration).

    I'm tearing down the mgcp process in IOS, still nothing

    I'm on c3825-adventerprisek9_ivs-mz.124-20.T3.bin and cucm 7.1.2.10000-4

    WIC Slot 0:
            T1 (2 port) Multi-Flex Trunk WAN daughter card
            Hardware revision 1.0           Board revision A0
            Serial number     36621981      Part number    800-04477-05
            Version Identifier     V02      FRU Part Number     VWIC-2MFT-T1     
            Test history      0x0           RMA number     00-00-00
            Connector type    PCI
            EEPROM format version 1
            EEPROM contents (hex):
              0x20: 01 22 01 00 02 2E CE 9D 50 11 7D 05 00 00 00 00
              0x30: 50 00 00 00 08 08 19 00 FF FF FF FF FF FF FF FF

    any other thoughts?

    thanks,

    voicedog

     

  • Can you post your config here? Also, anyway you can post a screenshot?

     

    Thanks

  • Here it is Josh, thanks for helping out. Let me know if you have trouble seeing the screenshots

    image

    image

    image

    HQ-RTR(config)#do sh run
    Building configuration...


    Current configuration : 3645 bytes
    !
    ! Last configuration change at 18:08:19 PST Thu Jan 21 2010
    ! NVRAM config last updated at 18:17:57 PST Thu Jan 21 2010
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname HQ-RTR
    !
    boot-start-marker
    boot-end-marker
    !
    logging message-counter syslog
    logging buffered 51200 warnings
    !
    no aaa new-model
    memory-size iomem 20
    clock timezone PST -8
    network-clock-participate wic 0
    network-clock-select 1 T1 0/0/0
    !
    dot11 syslog
    no ip source-route
    ip cef
    !
    !
    ip dhcp excluded-address 10.10.100.1
    ip dhcp excluded-address 10.10.200.1 10.10.200.49
    ip dhcp excluded-address 10.10.200.61 10.10.200.254
    !
    ip dhcp pool DATA-VLAN10
       import all
       network 10.10.100.0 255.255.255.0
       default-router 10.10.100.1
       dns-server 64.102.6.247 72.163.47.11 171.68.226.120
       option 150 ip 10.10.100.2
    !
    ip dhcp pool HQ-Phones
       network 10.10.200.0 255.255.255.0
       default-router 10.10.200.3
       option 150 ip 10.10.210.10
    !
    !        
    no ip domain lookup
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    voice-card 0
     no dspfarm
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !        
    !
    !
    !
    !
    !
    !
    !
    archive
     log config
      hidekeys
    !
    !
    !
    !
    !
    controller T1 0/0/0
     framing esf
     linecode b8zs
     ds0-group 0 timeslots 1-3 type e&m-wink-start
    !
    controller T1 0/0/1
     framing esf
     linecode b8zs
     channel-group 0 timeslots 1-24
    !
    !
    !
    !
    !
    interface Loopback0
     ip address 10.10.110.1 255.255.255.255
    !
    interface GigabitEthernet0/0
     no ip address
     duplex full
     speed 100
     media-type rj45
    !
    interface GigabitEthernet0/0.10
     encapsulation dot1Q 10 native
     ip address 10.10.100.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly
    !
    interface GigabitEthernet0/0.20
     encapsulation dot1Q 20
     ip address 10.10.200.3 255.255.255.0
     ip helper-address 10.10.210.10
    !
    interface GigabitEthernet0/0.30
     encapsulation dot1Q 30
     ip address 10.10.210.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly
    !
    interface GigabitEthernet0/1
     ip address dhcp
     ip nat outside
     ip virtual-reassembly
     duplex auto
     speed auto
     media-type rj45
    !
    interface Serial0/0/1:0
     no ip address
     encapsulation frame-relay IETF
     frame-relay lmi-type ansi
    !
    interface Serial0/0/1:0.1 point-to-point
     ip address 10.10.111.1 255.255.255.0
     ip ospf mtu-ignore
     snmp trap link-status
     frame-relay interface-dlci 201  
    !
    interface Serial0/0/1:0.2 point-to-point
     ip address 10.10.112.1 255.255.255.0
     ip ospf mtu-ignore
     snmp trap link-status
     frame-relay interface-dlci 202  
    !
    router ospf 1
     router-id 10.10.100.1
     log-adjacency-changes
     network 10.10.0.0 0.0.255.255 area 0
    !
    ip forward-protocol nd
    no ip http server
    ip http authentication local
    no ip http secure-server
    !
    !
    ip nat inside source list LAN interface GigabitEthernet0/1 overload
    !
    ip access-list extended LAN
     permit ip 10.10.100.0 0.0.0.255 any
     permit ip 10.10.210.0 0.0.0.255 any
    !
    !
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    voice-port 0/0/0:0
    !
    ccm-manager switchback immediate
    ccm-manager redundant-host 10.10.210.10
    ccm-manager mgcp
    !
    mgcp     
    mgcp call-agent 10.10.210.11 service-type mgcp version 0.1
    mgcp dtmf-relay voip codec all mode out-of-band
    mgcp bind control source-interface Loopback0
    mgcp bind media source-interface Loopback0
    !
    mgcp profile default
    !
    !
    !
    !
    !
    !
    gatekeeper
     shutdown
    !
    !
    line con 0
     exec-timeout 0 0
     logging synchronous
    line aux 0
    line vty 0 4
     exec-timeout 0 0
     privilege level 15
     logging synchronous
     no login
     transport preferred none
     transport input telnet
    line vty 5 15
     exec-timeout 0 0
     privilege level 15
     logging synchronous
     no login
     transport preferred none
     transport input telnet
    !
    scheduler allocate 20000 1000
    ntp source Loopback0
    ntp master 7
    end

  • also router is saying registered:

    HQ-RTR(config)#do sh ccm-manager                
    MGCP Domain Name: HQ-RTR
    Priority        Status                   Host
    ============================================================
    Primary         Registered               10.10.210.11
    First Backup    Backup Ready             10.10.210.10
    Second Backup   None                    

    Current active Call Manager:    10.10.210.11
    Backhaul/Redundant link port:   2428
    Failover Interval:              30 seconds
    Keepalive Interval:             15 seconds
    Last keepalive sent:            19:07:23 PST Jan 21 2010 (elapsed time: 00:00:08)
    Last MGCP traffic time:         19:07:23 PST Jan 21 2010 (elapsed time: 00:00:08)
    Last failover time:             18:16:42 PST Jan 21 2010 from (10.10.210.11)
    Last switchback time:           18:17:27 PST Jan 21 2010 from (10.10.210.10)
    Switchback mode:                Immediate
    MGCP Fallback mode:             Not Selected
    Last MGCP Fallback start time:  None
    Last MGCP Fallback end time:    None
    MGCP Download Tones:            Disabled
    TFTP retry count to shut Ports: 2
             
    FAX mode: cisco
    Configuration Error History:
    HQ-RTR(config)#

  • Configuration is looking fine.

     

    Try a restart on the gateway configuration page, then a no mgcp on the gateway, followed by a mgcp

    Unless you have already done this. If so, then try to restart the RIS data collector service, from the Serviceability subsystem, under the Network features.

  • our good buddy RIS data collector rears its ugly head again!

     

    also, are your pub and sub in sync?

  • I'm at a loss. I'm going to skip for now. Let me know if you think of anything else to try

    Thanks,

    voicedog

  • Follow the instructions at the start of the section to check on the database replication status......you seem to be SO close to conquering this!

  • I know I feel so close, but I've been on this issue for 2 days now. I need to move on for now. I'll come back to it.

     

    I checked dbreplication and I have my zeros. pub to sub replication looks good.

  • I'm probably being nit picky, but I noticed that your gateway is listed as HQ but it's in the DP_BR1 device pool. I also notice the switchback types on the router and CUCM are different.

     

    Not sure if these items are relevant.

     

    Did you restart RIS Data Collector on both devices?

     

    If not, I'd try shutting down MGCP, then restarting the RIS Data Collector on both servers, then restarting MGCP on the router.

     

    I'd also see what happens if you stop the call manager services on the Sub and force the gateway to register with the pub.

     

    Finally you can always restart the servers themselves. If you're leaving it alone for the night, wouldn't hurt.

     

     

     

     

  • Looked at the configs

     

    The missing portion is 

     

    dial-peer voice 1 pots

    service mgcpapp

     port 0/0/0:0

     

    For isdn u dont need dialpeers for voice ports to register ,but for T1 CAS or FXO ports u need this command.

    Thanks,

    Adam

     

Sign In or Register to comment.