in
IEOC CCIE Forums

IEOC - INE's Online Community

Welcome to INE's Online Community - IEOC - a place for CCIE and CCENT candidates to connect, share, and learn. Our Online Community features CCIE forums and discussions for all tracks including Routing & Switching, Voice, Security, Service Provider, Wireless,, and Storage. Through these online communities you can discuss your questions with thousands of your peers, hundreds of CCIE's and INE's own team of world renowned CCIE instructors and authors, Brian Dennis - Quintuple CCIE #2210, Brian McGahan – Triple CCIE #8593, Petr Lapukhov - Quad CCIE #16379, and Mark Snow - Dual CCIE #14073.
Latest post 01-07-2017 7:26 AM by Lachlan748. 0 replies.
Page 1 of 1 (1 items)
Sort Posts: Previous Next
  • 01-07-2017 7:26 AM

    EIGRP OTP and poison reverse

    Hi all,

    I need some help with an EIGRP poison reverse issue. I've setup an EIGRP OTP lab config using the INE lab topology. The lab simulates 4 x sites connected to an mpls core. One of those sites acts as EIGRP RR for OTP.

    The problem I have is, even though my OTP RR has split-horizon disabled, my spokes are receiving some advertisements from the RR with an infinite metric, so they're never making it into the topology table or RIB. Others are being learnt correctly.

    Can anyone explain why?

     

    More info:

    Site A: PE is R5, CE is R8, behind R8 is R10

    Site B: PE is R3, CE is R7, behind R7 is R9

    Site C: PE is R2, CE is R11, behind R11 is R12

    Site D: PE is R1, CE is R6, also acting as OTP RR.

     

    Sites A/B/C form a LISP tunnel back to R6, EIGRP neighbours appear, loopbacks for R9/R10/R12 are learnt, however, connected transit LAN and local LAN segments such as 155.1.10.0/24 and 155.1.108.0/24 are not being learnt. I have no other routing protocol running on the CE's, no loops that I can see, no SIA routes. 

     

    R7 EIGRP logs indicate:

     

    R7#show ip eigrp events  | inc 155.1.10.0

    422  15:00:23.434 Ignored route, inaccessible: 155.1.10.0/24 metric(Infinity) 

    455  15:00:19.794 NDB delete: 155.1.10.0/24 1 

    456  15:00:19.794 RDB delete: 155.1.10.0/24 155.1.58.8 

    461  15:00:19.734 Send reply: 155.1.10.0/24 155.1.146.6 

    464  15:00:19.734 Rcv query dest/nh: 155.1.10.0/24 155.1.58.8 

    465  15:00:19.734 Metric set: 155.1.10.0/24 metric(Infinity) 

     

    The odd thing is, R7 (CE) learns R10's loopback, but not its LAN segment:

     

    R7#show ip route 150.1.10.10

    Routing entry for 150.1.10.10/32

      Known via "eigrp 100", distance 90, metric 93999451, type internal

      Redistributing via eigrp 100

      Last update from 155.1.58.8 on LISP0, 23:31:42 ago

      Routing Descriptor Blocks:

      * 155.1.58.8, from 155.1.146.6, 23:31:42 ago, via LISP0

          Route metric is 93999451, traffic share count is 1

          Total delay is 5021 microseconds, minimum bandwidth is 56 Kbit

          Reliability 255/255, minimum MTU 1500 bytes

          Loading 1/255, Hops 2

    R7#show ip route 155.1.10.0 

    % Subnet not in table

     

    R7#show ip eigrp neighbors 

    EIGRP-IPv4 VR(OTP-TEST) Address-Family Neighbors for AS(100)

    H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq

                                                       (sec)         (ms)       Cnt Num

    1   155.1.146.6             Gi1.37                   12 23:34:23  813  4878  0  70

    0   155.1.79.9              Gi1.79                   12 1d03h       1   100  0  45

     

    Someone please help!

     

    Thanks,

    Lachlan

     

    • Post Points: 5
Page 1 of 1 (1 items)
IEOC CCIE Forums Internetwork Expert CCIE Training
About IEOC | Terms of Use | RSS | Privacy Policy
© 2010 Internetwork Expert, Inc. All Rights Reserved